Some Suggestions

Mar 5, 2013 at 8:15 PM
You use ints for things which should be enums:
        // 0 if asleep, 1 if awake, 2 if moving
        private int stateOfWumpus;
should be
       public enum WampusState {Asleep, Awake, Moving};
       private WampusState stateOfWumpus;
Also, most of the method you've defined so far really should be properties:
      public int getWumpusRoomNumber()
        {
            return wumpusRoomNumber;
        }
should be
      public int WumpusRoomNumber
        {
            get { return wumpusRoomNumber; }
        }